summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-03 17:24:22 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-02 15:23:36 +0100
commit34208bf51c465e06598de356f0a2f9d256dcfae1 (patch)
treee8a37de9f15319b948d0bf3deeb89edd649350f4
parent1ec2c14372bc19c0e02469caee1ebf295496efe6 (diff)
downloadpatches-34208bf51c465e06598de356f0a2f9d256dcfae1.tar
patches-34208bf51c465e06598de356f0a2f9d256dcfae1.tar.gz
gnu: Add t4k-common.
* gnu/packages/education.scm (t4k-common): New variable.
-rw-r--r--gnu/packages/education.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 1c326809cf..5cb836fc50 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages javascript)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
@@ -713,3 +714,49 @@ each key. A collection of lessons are included for a wide range of different
languages and keyboard layouts, and typing statistics are used to dynamically
adjust the level of difficulty.")
(license license:gpl2)))
+
+(define-public t4k-common
+ (package
+ (name "t4k-common")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tux4kids/t4kcommon")
+ (commit (string-append "upstream/" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13q02xpmps9qg8zrzzy2gzv4a6afgi28lxk4z242j780v0gphchp"))
+ (patches
+ (search-patches "t4k-common-libpng16.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;FIXME: cannot find how to run tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
+ "/include/SDL:"
+ (or (getenv "CPATH") "")))))
+ (add-after 'unpack 'fix-andika-font-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/t4k_sdl.c"
+ (("(/usr/share/.*?)/AndikaDesRevG\\.ttf")
+ (string-append (assoc-ref inputs "font-andika")
+ "/share/fonts/truetype")))
+ #t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("font-andika" ,font-sil-andika)
+ ("libpng" ,libpng)
+ ("librsvg" ,librsvg)
+ ("libxml2" ,libxml2)
+ ("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-net sdl-pango)))))
+ (home-page "https://github.com/tux4kids/t4kcommon")
+ (synopsis "Library of code shared between TuxMath and TuxType")
+ (description "Tux4Kids-Common is a library of code shared between
+TuxMath and TuxType.")
+ (license license:gpl3+)))