summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmin Bandali <mab@gnu.org>2020-02-02 15:19:33 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-02-02 15:19:33 +0100
commit1ec2c14372bc19c0e02469caee1ebf295496efe6 (patch)
tree1f6a30654b70bf9b32e41cebfaf169344f22ce3f
parent2cb9b0453d87aaad15cb5c43702dfa8a109c53cb (diff)
downloadpatches-1ec2c14372bc19c0e02469caee1ebf295496efe6.tar
patches-1ec2c14372bc19c0e02469caee1ebf295496efe6.tar.gz
gnu: Add emacs-erc-scrolltoplace.
* gnu/packages/emacs-xyz.scm (emacs-erc-scrolltoplace): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3e8174663f..8265b44d88 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21261,6 +21261,28 @@ hooks are run. The hooked functions will be called with both the previous and
the current buffer.")
(license license:unlicense)))
+(define-public emacs-erc-scrolltoplace
+ (package
+ (name "emacs-erc-scrolltoplace")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/jgkamat/erc-scrolltoplace.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11zpqwh1mlfifbgnvhc63bvnhg340jgxssm3m43hr1sxsyb52lh6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-switch-buffer-functions" ,emacs-switch-buffer-functions)))
+ (home-page "https://gitlab.com/jgkamat/erc-scrolltoplace")
+ (synopsis "ERC module to replace scrolltobottom while using keep-place")
+ (description "@code{erc-scrolltoplace} is an ERC module to try
+to emulate @code{scrolltobottom} while @code{keep-place} is enabled.")
+ (license license:gpl3+)))
+
(define-public emacs-dmenu
;; Use the latest commit, as there are no tagged releases.
(let ((commit "e8cc9b27c79d3ecc252267c082ab8e9c82eab264")