summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 01:08:06 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commitf0b21b8d3c813ec6f805b78211d424d7f236a822 (patch)
tree9934de0040574903405620fc7e29901d7684cadb
parentbf6bfdbe9ff5ab157c09e719e323334d7a811e5f (diff)
downloadpatches-f0b21b8d3c813ec6f805b78211d424d7f236a822.tar
patches-f0b21b8d3c813ec6f805b78211d424d7f236a822.tar.gz
gnu: Add kigo.
* gnu/packages/games.scm (kigo): New variable.
-rw-r--r--gnu/packages/games.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e758f43e1f..0b1be65695 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8951,3 +8951,51 @@ per single turn to make combinations with the highest score.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kigo
+ (package
+ (name "kigo")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kigo-" version ".tar.xz"))
+ (sha256
+ (base32 "00l5gcbi8xyj9c1lngkrddka3a4m4cd78prfplrpq32ma9xq681f"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("knewstuff", knewstuff)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtsvg" ,qtsvg)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Go board game")
+ (description "Kigo is an open-source implementation of the popular Go
+game.
+
+Go is a strategic board game for two players. It is also known as
+igo (Japanese), weiqi or wei ch'i (Chinese) or baduk (Korean). Go is noted
+for being rich in strategic complexity despite its simple rules. The game is
+played by two players who alternately place black and white stones (playing
+pieces, now usually made of glass or plastic) on the vacant intersections of a
+grid of 19x19 lines (9x9 or 13x13 for easier games).
+
+You also need to install a go engine, e.g. @code{gnugo}.
+
+This package is part of the KDE games module.")
+ (license license:gpl3+)))