summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-30 17:26:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-30 17:46:48 +0100
commite5d71802fc58bc3ebb1ef8afdca63adbca169a48 (patch)
tree31e9ceea278c633efe2bb602c05070fa9504f61c
parent14db8f192e974768d0608c2c5a95a4cfe595487e (diff)
downloadpatches-e5d71802fc58bc3ebb1ef8afdca63adbca169a48.tar
patches-e5d71802fc58bc3ebb1ef8afdca63adbca169a48.tar.gz
gnu: Add python-bonsai.
* gnu/packages/openldap.scm (python-bonsai): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/openldap.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 7abe9ab6f0..de8239b7fe 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,7 +49,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages web)
#:use-module (gnu packages)
- #:use-module ((guix licenses) #:select (openldap2.8 lgpl2.1+ gpl3+ psfl))
+ #:use-module ((guix licenses) #:select (openldap2.8 lgpl2.1+ gpl3+ psfl expat))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -367,3 +368,30 @@ Other features include:
@end enumerate\n")
;; GPLv3+ with OpenSSL linking exception.
(license gpl3+)))
+
+(define-public python-bonsai
+ (package
+ (name "python-bonsai")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bonsai" version))
+ (sha256
+ (base32
+ "013bl6h1m3f7vg1lk89d4vi28wbf31zdcs4f9g8css7ngx63v6px"))))
+ (build-system python-build-system)
+ (inputs
+ `(("mit-krb5" ,mit-krb5)
+ ("cyrus-sasl" ,cyrus-sasl)
+ ("openldap" ,openldap)))
+ ;; disabling tests, since they require docker and extensive setup
+ (arguments `(#:tests? #f))
+ (home-page "https://github.com/noirello/bonsai")
+ (synopsis "Access LDAP directory servers from Python")
+ (description
+ "This is a module for handling LDAP operations in Python. LDAP entries
+are mapped to a special Python case-insensitive dictionary, tracking the
+changes of the dictionary to modify the entry on the server easily.")
+ (license expat)))
+