summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-22 20:58:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:44 +0100
commitdf3d90c7a4910034f28eee34f670963b25773f28 (patch)
treebf146f529319689f394f54be20a129413aa2a143
parentf4195446f3de110dd7941bd9c45c761666e6ab6f (diff)
downloadpatches-df3d90c7a4910034f28eee34f670963b25773f28.tar
patches-df3d90c7a4910034f28eee34f670963b25773f28.tar.gz
gnu: Add kmines.
* gnu/packages/games.scm (kmines): New variable.
-rw-r--r--gnu/packages/games.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 95d0bc93eb..84fe37d48d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8246,3 +8246,42 @@ by bouncing balls against them.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public kmines
+ (package
+ (name "kmines")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kmines-" version ".tar.xz"))
+ (sha256
+ (base32 "0ac3za36lh8hpx6mqfic9amwmzhzhzplm9hg3pw12gxl5a9mvfsf"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Classical mine sweeper game")
+ (description "KMines is a classic Minesweeper game. The idea is to
+uncover all the squares without blowing up any mines. When a mine is blown
+up, the game is over.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))