summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-01-28 19:25:38 +0100
committerChristopher Baines <mail@cbaines.net>2020-01-29 07:56:32 +0000
commitd868261533c4f315dd4812c86f174c3d1a1b08b2 (patch)
tree03d7ca6f1a98f5e43e2297d3600e93e2a58059f3
parente19e3430cdb7c884ac6f91a618aafa6bb94554be (diff)
downloadpatches-d868261533c4f315dd4812c86f174c3d1a1b08b2.tar
patches-d868261533c4f315dd4812c86f174c3d1a1b08b2.tar.gz
gnu: godot: Update to 3.1.2.
* gnu/packages/game-development.scm (godot): Update to 3.1.2. [inputs]: Remove openssl, replaced by a bundled copy of mbedtls. [arguments](configure-flags): Remove builtin_openssl flag. [source]: Don’t try to remove the (now nonexistent) bundled openssl directory. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 2498f6f39d..bbc9cbc0bd 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1503,7 +1504,7 @@ games.")
(define-public godot
(package
(name "godot")
- (version "3.0.6")
+ (version "3.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1512,7 +1513,7 @@ games.")
(file-name (git-file-name name version))
(sha256
(base32
- "0g64h0x8dlv6aa9ggfcidk2mknkfl5li7z1phcav8aqp9srj8avf"))
+ "12305wj2i4067jc50l8r0wmb7zjcna24fli8vb8kiaild0jrlip6"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1527,7 +1528,6 @@ games.")
"libvorbis"
"libvpx"
"libwebp"
- "openssl"
"opus"
"zlib"))
#t)))))
@@ -1550,7 +1550,6 @@ games.")
"builtin_libvorbis=no"
"builtin_libvpx=no"
"builtin_libwebp=no"
- "builtin_openssl=no"
"builtin_opus=no"
"builtin_zlib=no")
#:tests? #f ; There are no tests
@@ -1612,7 +1611,6 @@ games.")
("libxinerama" ,libxinerama)
("libxrandr" ,libxrandr)
("mesa" ,mesa)
- ("openssl" ,openssl)
("opusfile" ,opusfile)
("pulseaudio" ,pulseaudio)))
(home-page "https://godotengine.org/")