summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-01-28 14:26:49 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2020-01-28 14:26:49 +0100
commitd823fd96b5a62e0d3d9bed08afc228dc52f7ba06 (patch)
tree341f55b16af70f2a6dd70fdde6ba03963ae5b57e
parentf4167bdad7a98fd1248b8fff4d18c56d91427514 (diff)
downloadpatches-d823fd96b5a62e0d3d9bed08afc228dc52f7ba06.tar
patches-d823fd96b5a62e0d3d9bed08afc228dc52f7ba06.tar.gz
gnu: Add bruteforce-luks.
* gnu/packages/password-utils.scm (bruteforce-luks): New variable.
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 5f297e117a..8d74490d23 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages cryptsetup)
#:use-module (gnu packages curl)
#:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
@@ -1066,3 +1068,30 @@ binaries. All of these utils are designed to execute only one specific
function. Since they all work with @code{STDIN} and @code{STDOUT} you can
group them into chains.")
(license license:expat)))
+
+(define-public bruteforce-luks
+ (package
+ (name "bruteforce-luks")
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/glv2/bruteforce-luks/releases/download/"
+ version
+ "/bruteforce-luks-"
+ version
+ ".tar.lz"))
+ (sha256
+ (base32 "0yawrlbbklhmvwr99wm7li3r0d5kxvpkwf33a12rji7z0ya5p340"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("lzip" ,lzip)))
+ (inputs
+ `(("cryptsetup" ,cryptsetup)))
+ (synopsis "LUKS encrypted volume cracker")
+ (description
+ "This is a cracker for LUKS encrypted volumes. It can be used either in
+exhaustive mode to try every password given a charset or in dictionary mode to
+try every password contained in a file.")
+ (home-page "https://github.com/glv2/bruteforce-luks")
+ (license license:gpl3+)))