summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-01-28 19:25:39 +0100
committerChristopher Baines <mail@cbaines.net>2020-01-29 07:57:03 +0000
commitc1bc92c0aa02d8967107efe45dbb27fe824f17a4 (patch)
tree853fb83141aa3143a9d9ef7906ecb5575145a21a
parentd868261533c4f315dd4812c86f174c3d1a1b08b2 (diff)
downloadpatches-c1bc92c0aa02d8967107efe45dbb27fe824f17a4.tar
patches-c1bc92c0aa02d8967107efe45dbb27fe824f17a4.tar.gz
gnu: godot: Unbundle some dependencies.
* gnu/packages/game-development.scm (godot)[inputs]: Add bullet, mbedtls-apache, pcre2 and zstd. [arguments](configure-flags): Use system libraries for the above. [source](snippet): Remove bundled copies. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/game-development.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index bbc9cbc0bd..47fc9a72a7 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
@@ -1521,15 +1522,19 @@ games.")
;; of these may be modified; see "thirdparty/README.md".
(with-directory-excursion "thirdparty"
(for-each delete-file-recursively
- '("freetype"
+ '("bullet"
+ "freetype"
"libogg"
"libpng"
"libtheora"
"libvorbis"
"libvpx"
"libwebp"
+ "mbedtls"
"opus"
- "zlib"))
+ "pcre2"
+ "zlib"
+ "zstd"))
#t)))))
(build-system scons-build-system)
(arguments
@@ -1541,6 +1546,7 @@ games.")
'())
;; Avoid using many of the bundled libs.
;; Note: These options can be found in the SConstruct file.
+ "builtin_bullet=no"
"builtin_freetype=no"
"builtin_glew=no"
"builtin_libmpdec=no"
@@ -1550,8 +1556,11 @@ games.")
"builtin_libvorbis=no"
"builtin_libvpx=no"
"builtin_libwebp=no"
+ "builtin_mbedtls=no"
"builtin_opus=no"
- "builtin_zlib=no")
+ "builtin_pcre2=no"
+ "builtin_zlib=no"
+ "builtin_zstd=no")
#:tests? #f ; There are no tests
#:phases
(modify-phases %standard-phases
@@ -1598,6 +1607,7 @@ games.")
#t))))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("alsa-lib" ,alsa-lib)
+ ("bullet" ,bullet)
("freetype" ,freetype)
("glew" ,glew)
("glu" ,glu)
@@ -1610,9 +1620,12 @@ games.")
("libxi" ,libxi)
("libxinerama" ,libxinerama)
("libxrandr" ,libxrandr)
+ ("mbedtls" ,mbedtls-apache)
("mesa" ,mesa)
("opusfile" ,opusfile)
- ("pulseaudio" ,pulseaudio)))
+ ("pcre2" ,pcre2)
+ ("pulseaudio" ,pulseaudio)
+ ("zstd" ,zstd "lib")))
(home-page "https://godotengine.org/")
(synopsis "Advanced 2D and 3D game engine")
(description