summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-01-28 19:25:40 +0100
committerChristopher Baines <mail@cbaines.net>2020-01-29 07:57:09 +0000
commit18f8e935e85a99d5c284c0a6b719351a402ada21 (patch)
treea97afff0bdb60187be3c84535e1a2e82add34af2
parentc1bc92c0aa02d8967107efe45dbb27fe824f17a4 (diff)
downloadpatches-18f8e935e85a99d5c284c0a6b719351a402ada21.tar
patches-18f8e935e85a99d5c284c0a6b719351a402ada21.tar.gz
gnu: godot: List which third party files to keep.
Remove everything else to catch added dependencies in new versions. * gnu/packages/game-development.scm (godot)[source](snippet): Instead of removing (only) the unbundled libs, remove everything except the listed files. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/game-development.scm51
1 files changed, 33 insertions, 18 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 47fc9a72a7..ceec993d04 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1515,27 +1515,42 @@ games.")
(sha256
(base32
"12305wj2i4067jc50l8r0wmb7zjcna24fli8vb8kiaild0jrlip6"))
- (modules '((guix build utils)))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-1)))
(snippet
'(begin
- ;; Drop libraries that we take from Guix. Note that some
- ;; of these may be modified; see "thirdparty/README.md".
+ ;; Keep only those bundled files we have not (yet) replaced
+ ;; with Guix versions. Note that some of these may be
+ ;; modified; see "thirdparty/README.md".
(with-directory-excursion "thirdparty"
- (for-each delete-file-recursively
- '("bullet"
- "freetype"
- "libogg"
- "libpng"
- "libtheora"
- "libvorbis"
- "libvpx"
- "libwebp"
- "mbedtls"
- "opus"
- "pcre2"
- "zlib"
- "zstd"))
- #t)))))
+ (let* ((preserved-files
+ '("README.md"
+ "b2d_convexdecomp"
+ "certs"
+ "cvtt"
+ "enet"
+ "etc2comp"
+ "fonts"
+ "glad"
+ "jpeg-compressor"
+ "libsimplewebm"
+ "libwebsockets"
+ "miniupnpc"
+ "minizip"
+ "misc"
+ "nanosvg"
+ "pvrtccompressor"
+ "recastnavigation"
+ "squish"
+ "thekla_atlas"
+ "tinyexr"
+ "xatlas")))
+ (for-each delete-file-recursively
+ (lset-difference string=?
+ (scandir ".")
+ (cons* "." ".." preserved-files)))))
+ #t))))
(build-system scons-build-system)
(arguments
`(#:scons ,scons-python2