summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-28 20:23:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-28 20:23:41 +0100
commit07a7cccbac59dd8265fffdd4b87616cd0419a2c7 (patch)
tree470ea1e4615a0e3b1ecad0132459485d83e52e76
parente7c938b2bf591819a64ea0ecb51a863d71339da2 (diff)
downloadpatches-07a7cccbac59dd8265fffdd4b87616cd0419a2c7.tar
patches-07a7cccbac59dd8265fffdd4b87616cd0419a2c7.tar.gz
gnu: ode: Properly disable tests when cross-compiling.
* gnu/packages/game-development.scm (ode): Properly disable tests when using (%current-target-system).
-rw-r--r--gnu/packages/game-development.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5160bcf2ea..2498f6f39d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1999,9 +1999,9 @@ a.k.a. XenoCollide) as described in Game Programming Gems 7.")
(build-system cmake-build-system)
(arguments
;; Tests fail on all systems but x86_64.
- `(#:tests? ,(string=? "x86_64-linux"
- (or (%current-target-system)
- (%current-system)))
+ `(#:tests? ,(string-prefix? "x86_64-"
+ (or (%current-target-system)
+ (%current-system)))
#:configure-flags '("-DODE_WITH_LIBCCD_SYSTEM=ON")
#:phases
(modify-phases %standard-phases