summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-14 00:50:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-28 00:36:39 +0100
commite53829be49901ac05127ebc73d33f9d6206606e9 (patch)
tree96595d20c01b3e7ee1b4c69297af9f2afe731057
parent412622ad661bb1d60cd520fba1d4c6a0280551d0 (diff)
downloadpatches-e53829be49901ac05127ebc73d33f9d6206606e9.tar
patches-e53829be49901ac05127ebc73d33f9d6206606e9.tar.gz
gnu: termite: Open links properly without xdg-utils in profile
* gnu/packages/terminals.scm (termite)[inputs]: Add XDG-UTILS. [arguments](patch-xdg-open): New phase. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/terminals.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index b5c3b69f53..dae14aee8f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -138,6 +139,11 @@ configurable through a graphical wizard.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-xdg-open
+ (lambda _
+ (substitute* "termite.cc"
+ (("xdg-open") (which "xdg-open")))
+ #t))
(delete 'configure))
#:tests? #f
;; This sets the destination when installing the necessary terminal
@@ -150,6 +156,7 @@ configurable through a graphical wizard.")
(inputs
`(("vte" ,vte-ng)
("gtk+" ,gtk+)
+ ("xdg-utils" ,xdg-utils)
("ncurses" ,ncurses)))
(native-inputs
`(("pkg-config" ,pkg-config)))