summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-25 21:48:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-27 18:36:11 +0200
commitad03f50fa80c0a5306de6b3efbd152bcf281164d (patch)
treefcb8ccb8258bd7984938af9cc9a9150f6ae5338f
parente2302953d55f598e6c2d9224e3377d7116e31608 (diff)
downloadpatches-ad03f50fa80c0a5306de6b3efbd152bcf281164d.tar
patches-ad03f50fa80c0a5306de6b3efbd152bcf281164d.tar.gz
gnu: rust-libssh2-sys-0.2: Remove vendored code.
* gnu/packages/crates-io.scm (rust-libssh2-sys-0.2)[source]: Remove vendored code. [arguments]: Don't remove missing vendored code. (rust-libgit2-sys-0.10)[arguments]: Same. * gnu/packages/rust-apps.scm (tokei)[arguments]: Same.
-rw-r--r--gnu/packages/crates-io.scm16
-rw-r--r--gnu/packages/rust-apps.scm4
2 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ea4a3f3e28..8ba8cde99a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5628,10 +5628,6 @@ values of all the exported APIs match the platform that libc is compiled for.")
(string-append "guix-vendor/rust-libz-sys-"
,(package-version rust-libz-sys-1.0)
".crate/src/zlib"))
- (delete-file-recursively
- (string-append "guix-vendor/rust-libssh2-sys-"
- ,(package-version rust-libssh2-sys-0.2)
- ".crate/libssh2"))
(setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
(setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
#t)))))
@@ -5716,10 +5712,13 @@ functions and static variables these libraries contain.")
(origin
(method url-fetch)
(uri (crate-uri "libssh2-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "042gsgbvxgm5by4mk906j3zm4qdvzcfhjxrb55is1lrr6f0nxain"))))
+ "042gsgbvxgm5by4mk906j3zm4qdvzcfhjxrb55is1lrr6f0nxain"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (delete-file-recursively "libssh2") #t))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t ; it wants rust-openssl-src
@@ -5737,11 +5736,6 @@ functions and static variables these libraries contain.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((openssl (assoc-ref inputs "openssl")))
(setenv "OPENSSL_DIR" openssl))
- (delete-file-recursively "libssh2")
- (delete-file-recursively
- (string-append "guix-vendor/rust-libssh2-sys-"
- ,(package-version rust-libssh2-sys-0.2)
- ".crate/libssh2"))
(delete-file-recursively
(string-append "guix-vendor/rust-libz-sys-"
,(package-version rust-libz-sys-1.0)
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 1b0721f546..2099e38fff 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -147,10 +147,6 @@ gitignore rules.")
(setenv "LIBGIT2_SYS_USE_PKG_CONFIG" "1")
(setenv "LIBSSH2_SYS_USE_PKG_CONFIG" "1")
(delete-file-recursively
- (string-append "guix-vendor/rust-libssh2-sys-"
- ,(package-version rust-libssh2-sys-0.2)
- ".crate/libssh2"))
- (delete-file-recursively
(string-append "guix-vendor/rust-libz-sys-"
,(package-version rust-libz-sys-1.0)
".crate/src/zlib")))