summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-01-20 20:21:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-27 22:31:19 +0100
commita38bf7c843c75a6ed55495c75c26ccc7afc44a00 (patch)
treed2901be509dfa0cd4c856526fdb416b27d83b686
parent4fc4e5fdd9da6320aa94eeec61cbb84a7dc9460e (diff)
downloadpatches-a38bf7c843c75a6ed55495c75c26ccc7afc44a00.tar
patches-a38bf7c843c75a6ed55495c75c26ccc7afc44a00.tar.gz
gnu: Add r-deconstructsigs.
* gnu/packages/bioconductor.scm (r-deconstructsigs): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 469f2897ae..c1da8ac106 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -694,6 +694,34 @@ annotations.")
"This is a manifest package for Illumina's EPIC methylation arrays.")
(license license:artistic2.0)))
+;; This is a CRAN package, but it depends on r-bsgenome-hsapiens-ucsc-hg19
+;; from Bioconductor.
+(define-public r-deconstructsigs
+ (package
+ (name "r-deconstructsigs")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "deconstructSigs" version))
+ (sha256
+ (base32
+ "014x0nb23jb98666kaav2phkvmkr38pi38jv0dqd4jv7zp0gdf1a"))))
+ (properties
+ `((upstream-name . "deconstructSigs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-reshape2" ,r-reshape2)))
+ (home-page "https://github.com/raerose01/deconstructSigs")
+ (synopsis "Identifies signatures present in a tumor sample")
+ (description "This package takes sample information in the form of the
+fraction of mutations in each of 96 trinucleotide contexts and identifies
+the weighted combination of published signatures that, when summed, most
+closely reconstructs the mutational profile.")
+ (license license:gpl2+)))
+
(define-public r-do-db
(package
(name "r-do-db")