summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-01-08 14:31:05 +0000
committerLudovic Courtès <ludo@gnu.org>2020-01-27 23:19:35 +0100
commit93f4511eb0c9b33f5083c2a04f4148e0a494059c (patch)
tree5a6f38682b5aa0465c1a996d23abe5bdbd061a5d
parent5d703da3f7475a5f3912361edf5217d29578d9a6 (diff)
downloadpatches-93f4511eb0c9b33f5083c2a04f4148e0a494059c.tar
patches-93f4511eb0c9b33f5083c2a04f4148e0a494059c.tar.gz
gnu: Add zrythm.
* gnu/packages/music.scm (zrythm): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/music.scm49
1 files changed, 48 insertions, 1 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 63e2686617..e378e9880b 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 raingloom <raingloom@protonmail.com>
;;; Copyright © 2019 David Wilson <david@daviwil.com>
-;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5138,3 +5138,50 @@ MIDI drums and comes as two separate drumkits: Black Pearl and Red Zeppelin.")
(description "Helm is a cross-platform polyphonic synthesizer available standalone
and as an LV2 plugin.")
(license license:gpl3+)))
+
+(define-public zrythm
+ (package
+ (name "zrythm")
+ (version "0.7.345")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.zrythm.org/releases/zrythm-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1csiwq38a1ckx23lairfpl7qjkz71wsa7a9vsxl3k58f9ybibiil"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:configure-flags
+ `("-Denable_tests=true" "-Dmanpage=true"
+ "-Dinstall_dseg_font=false" "-Denable_ffmpeg=true")))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("font-dseg", font-dseg)
+ ("ffmpeg", ffmpeg)
+ ("fftw", fftw)
+ ("fftwf", fftwf)
+ ("gettext", gettext-minimal)
+ ("glibc", glibc)
+ ("gtk+", gtk+)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libyaml" ,libyaml)
+ ("lilv", lilv)
+ ("xdg-utils", xdg-utils)
+ ("rubberband", rubberband)))
+ (native-inputs
+ `(("pkg-config", pkg-config)
+ ("help2man", help2man)
+ ("libaudec" ,libaudec)
+ ("lv2", lv2)
+ ("glib" ,glib "bin"))) ;for 'glib-compile-resources'
+ (synopsis "Digital audio workstation focusing on usability")
+ (description "Zrythm is a digital audio workstation designed to be
+featureful and easy to use. It offers unlimited automation options, LV2
+plugin support, JACK support and chord assistance.")
+ (home-page "https://www.zrythm.org")
+ (license license:agpl3+)))