summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-19 13:44:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-28 00:36:39 +0100
commit7ee8acbb76bd440a8985a4b2a20b75521c6853ed (patch)
tree8f6a45d86dd98f202eca00820b504751da832d3b
parente53829be49901ac05127ebc73d33f9d6206606e9 (diff)
downloadpatches-7ee8acbb76bd440a8985a4b2a20b75521c6853ed.tar
patches-7ee8acbb76bd440a8985a4b2a20b75521c6853ed.tar.gz
gnu: Add bvi.
* gnu/packages/hexedit.scm (bvi): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/hexedit.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 9aea8e8700..365b6dab08 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,3 +81,25 @@ low-level functionality of a debugger with the usability of an @dfn{Integrated
Development Environment} (IDE).")
(home-page "http://hte.sourceforge.net/")
(license license:gpl2)))
+
+(define-public bvi
+ (package
+ (name "bvi")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/bvi/bvi/" version
+ "/bvi-" version ".src.tar.gz"))
+ (sha256
+ (base32
+ "0a0yl0dcyff31k3dr4dpgqmlwygp8iaslnr5gmb6814ylxf2ad9h"))))
+ (build-system gnu-build-system)
+ (arguments '(#:tests? #f)) ; no check target
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (synopsis "Binary file editor")
+ (description "@command{bvi} is a display-oriented editor for binary files,
+based on the @command{vi} text editor.")
+ (home-page "http://bvi.sourceforge.net/")
+ (license license:gpl3+)))