summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-01-08 14:26:45 +0000
committerLudovic Courtès <ludo@gnu.org>2020-01-27 23:14:20 +0100
commit5d703da3f7475a5f3912361edf5217d29578d9a6 (patch)
tree06efcd20eb04fb6eaf221212715f3a1f8867f125
parent2d3a622d04de7b7f58192dc868b846ec416f95bf (diff)
downloadpatches-5d703da3f7475a5f3912361edf5217d29578d9a6.tar
patches-5d703da3f7475a5f3912361edf5217d29578d9a6.tar.gz
gnu: Add libaudec.
* gnu/packages/audio.scm (libaudec): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/audio.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 95222a5d81..c0fb800193 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,7 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019, 2020 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Christopher Lemmer Webber <cwebber@dustycloud.org>
;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;; Copyright © 2019 Hartmt Goebel <h.goebel@crazy-compilers.com>
@@ -54,6 +54,7 @@
#:use-module (guix build-system waf)
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson)
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module (gnu packages)
@@ -4009,3 +4010,33 @@ in the package.")
;; (see the file 'COPYING.LGPL'). This allows writing ECI applications
;; that are not licensed under GPL.
(license (list license:gpl2 license:lgpl2.1))))
+
+(define-public libaudec
+ (package
+ (name "libaudec")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.zrythm.org/git/libaudec")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0lfydvs92b0hr72z71ci3yi356rjzi162pgms8dphgg18bz8dazv"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags `("-Denable_tests=true -Denable_ffmpeg=true")))
+ (inputs
+ `(("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("ffmpeg" ,ffmpeg)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Library for reading and resampling audio files")
+ (description "libaudec is a wrapper library over ffmpeg, sndfile and
+libsamplerate for reading and resampling audio files, based on Robin Gareus'
+@code{audio_decoder} code.")
+ (home-page "https://git.zrythm.org/cgit/libaudec")
+ (license license:agpl3+)))