summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2020-01-28 00:32:06 +0100
committerGábor Boskovits <boskovits@gmail.com>2020-01-28 00:32:06 +0100
commit412622ad661bb1d60cd520fba1d4c6a0280551d0 (patch)
treee04f42b4d710a81b6081594daf7cb16b6559430a
parent93f4511eb0c9b33f5083c2a04f4148e0a494059c (diff)
downloadpatches-412622ad661bb1d60cd520fba1d4c6a0280551d0.tar
patches-412622ad661bb1d60cd520fba1d4c6a0280551d0.tar.gz
gnu: go-github-com-prometheus-node-exporter: Update to 0.18.1.
* gnu/packages/monitoring.scm (go-github-com-prometheus-node-exporter): Update to 0.18.1.
-rw-r--r--gnu/packages/monitoring.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 78f94bbe4b..1eb095ce50 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -401,28 +401,26 @@ WSGI and the node exporter textfile collector.")
(package-with-python2 python-prometheus-client))
(define-public go-github-com-prometheus-node-exporter
- (let ((commit "55c32fcf02492fe4946f7ab563547cc5df7fc61e")
- (revision "0"))
- (package
- (name "go-github-com-prometheus-node-exporter")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/node_exporter.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "041b87a0sid23c29swqmi5hw6cxbxvkfj3415jg73cm2pi8wh5s6"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/node_exporter"))
- (synopsis "Prometheus exporter for hardware and OS metrics")
- (description "Prometheus exporter for metrics exposed by *NIX kernels,
+ (package
+ (name "go-github-com-prometheus-node-exporter")
+ (version "0.18.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/node_exporter.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s3sp1gj86p7npxl38hkgs6ymd3wjjmc5hydyg1b5wh0x3yvpx07"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/node_exporter"))
+ (synopsis "Prometheus exporter for hardware and OS metrics")
+ (description "Prometheus exporter for metrics exposed by *NIX kernels,
written in Go with pluggable metric collectors.")
- (home-page "https://github.com/prometheus/node_exporter")
- (license license:asl2.0))))
+ (home-page "https://github.com/prometheus/node_exporter")
+ (license license:asl2.0)))
(define-public fswatch
(package