summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmin Bandali <mab@gnu.org>2020-01-28 10:28:04 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-01-28 10:28:04 +0100
commit2fe83ce10fcfc50d49cdafe2d6981adaf4a27d9d (patch)
tree1e1111600424364c95cadacc2a545fe45a7789a3
parentc8f16c7f7e043bdcfbdffdd09909778adecb9160 (diff)
downloadpatches-2fe83ce10fcfc50d49cdafe2d6981adaf4a27d9d.tar
patches-2fe83ce10fcfc50d49cdafe2d6981adaf4a27d9d.tar.gz
gnu: Add emacs-delight.
* gnu/packages/emacs-xyz.scm (emacs-delight): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a7377d8e42..e5af72121a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21194,3 +21194,21 @@ by Jan Tatarik.")
various line positions, like moving to the beginning/end of code, line, or
comment.")
(license license:gpl3+))))
+
+(define-public emacs-delight
+ (package
+ (name "emacs-delight")
+ (version "1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "delight-" version ".el"))
+ (sha256
+ (base32 "0kzlvzwmn6zj0874086q2xw0pclyi7wlkq48zh2lkd2796xm8vw7"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/delight.html")
+ (synopsis "Dimmer switch for your mode-line lighter text")
+ (description "@code{delight} enables customizing or hiding the
+mode-line text (lighter) of major and minor modes.")
+ (license license:gpl3+)))