summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-25 21:57:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-27 18:36:12 +0200
commitd0c4d1abfe54c12a0dfa467267859802f65c3bbc (patch)
treebcdc9770881680d81316a01bca0218c12210f9cc
parentd6dde77d7ff2aeb63b8b4ddbca6b518d84aa87ed (diff)
downloadpatches-d0c4d1abfe54c12a0dfa467267859802f65c3bbc.tar
patches-d0c4d1abfe54c12a0dfa467267859802f65c3bbc.tar.gz
gnu: rust-pcre2-sys-0.2: Delete vendored code.
* gnu/packages/crates-io.scm (rust-pcre2-sys-0.2)[source]: Delete vendored code. [arguments]: Remove custom phase. (rust-pcre2-0.2, rust-grep-pcre2-0.1)[arguments]: Enable build. [native-inputs]: Add pkg-config, pcre2.
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 278b14e6f1..1099a25d87 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4408,10 +4408,12 @@ the regex engine it uses pluggable.")
"1wjc3gsan20gapga8nji6jcrmwn9n85q5zf2yfq6g50c7abkc2ql"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-grep-matcher" ,rust-grep-matcher-0.1)
("rust-pcre2" ,rust-pcre2-0.2))))
+ (native-inputs
+ `(("pcre2" ,pcre2)
+ ("pkg-config" ,pkg-config)))
(home-page
"https://github.com/BurntSushi/ripgrep")
(synopsis "Use PCRE2 with the grep crate")
@@ -7490,12 +7492,14 @@ deserialization, and interpreter in Rust.")
"103i66a998g1fjrqf9sdyvi8qi83hwglz3pjdcq9n2r207hsagb0"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
("rust-log" ,rust-log-0.4)
("rust-pcre2-sys" ,rust-pcre2-sys-0.2)
("rust-thread-local" ,rust-thread-local-0.3))))
+ (native-inputs
+ `(("pcre2" ,pcre2)
+ ("pkg-config" ,pkg-config)))
(home-page "https://github.com/BurntSushi/rust-pcre2")
(synopsis "High level wrapper library for PCRE2")
(description
@@ -7514,23 +7518,16 @@ deserialization, and interpreter in Rust.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0nwdvc43dkb89qmm5q8gw1zyll0wsfqw7kczpn23mljra3874v47"))))
+ "0nwdvc43dkb89qmm5q8gw1zyll0wsfqw7kczpn23mljra3874v47"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (delete-file-recursively "pcre2") #t))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
("rust-pkg-config" ,rust-pkg-config-0.3)
- ("rust-cc" ,rust-cc-1.0))
- #:phases
- (modify-phases %standard-phases
- (add-after 'configure 'unbundle-sources
- (lambda _
- (delete-file-recursively "pcre2")
- (delete-file-recursively
- (string-append "guix-vendor/rust-pcre2-sys-"
- ,(package-version rust-pcre2-sys-0.2)
- ".tar.gz/pcre2"))
- #t)))))
+ ("rust-cc" ,rust-cc-1.0))))
(native-inputs
`(("pcre2" ,pcre2)
("pkg-config" ,pkg-config)))