summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-25 21:39:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-27 18:36:11 +0200
commita13db7e2ab05ee3ab9a42dd6a101130b8896fee0 (patch)
tree96110a09b17e52e90876673252f649cfa45d2633
parent2afae7fc9ae4ed29e798aabda83dcc4608c13240 (diff)
downloadpatches-a13db7e2ab05ee3ab9a42dd6a101130b8896fee0.tar
patches-a13db7e2ab05ee3ab9a42dd6a101130b8896fee0.tar.gz
build: cargo-build-system: Allow patched crates.
* guix/build/cargo-build-system.scm (crate-src?): Don't check for a gzipped tarball, just make sure it's not a directory.
-rw-r--r--guix/build/cargo-build-system.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build/cargo-build-system.scm b/guix/build/cargo-build-system.scm
index 8a8d74ee1b..78c27a29e4 100644
--- a/guix/build/cargo-build-system.scm
+++ b/guix/build/cargo-build-system.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,7 +58,7 @@
(define (crate-src? path)
"Check if PATH refers to a crate source, namely a gzipped tarball with a
Cargo.toml file present at its root."
- (and (gzip-file? path)
+ (and (not (directory-exists? path)) ; not a tarball
;; First we print out all file names within the tarball to see if it
;; looks like the source of a crate. However, the tarball will include
;; an extra path component which we would like to ignore (since we're