summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-13 00:15:21 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-26 18:50:11 +0100
commitfb4db07467fb764e7df64a4aacae13eaaf7f912c (patch)
treeaddea341fb33974836e8e3af5c16bbcfa6b928eb
parent2cb4ee2787281b0c155ab4794fa1251652251d3b (diff)
downloadpatches-fb4db07467fb764e7df64a4aacae13eaaf7f912c.tar
patches-fb4db07467fb764e7df64a4aacae13eaaf7f912c.tar.gz
gnu: Add python-argh.
* gnu/packages/python-xyz.scm (python-argh): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd68b49572..f8f2c95966 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17397,3 +17397,25 @@ for file systems paths.")
(description "This package allows Python developpers to capture their standard
output and standard error.")
(license license:expat)))
+
+(define-public python-argh
+ (package
+ (name "python-argh")
+ (version "0.26.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "argh" version))
+ (sha256
+ (base32
+ "0rdv0n2aa181mkrybwvl3czkrrikgzd4y2cri6j735fwhj65nlz9"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-iocapture" ,python-iocapture)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/neithere/argh/")
+ (synopsis "Argparse wrapper with natural syntax")
+ (description "This package provides a parser for dealing with command-line
+arguments in Python.")
+ (license license:lgpl3)))