summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-13 00:02:43 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-26 18:50:05 +0100
commitb487b7b5bb7702209b719d155f6938c08bd2f1e3 (patch)
treee415bb8b104ffbe723c722ea3afe66cafac5b3fa
parentad429e0de74eb087097ed383e2cda046321e5dc2 (diff)
downloadpatches-b487b7b5bb7702209b719d155f6938c08bd2f1e3.tar
patches-b487b7b5bb7702209b719d155f6938c08bd2f1e3.tar.gz
gnu: Add python-android-stringslib.
* gnu/packages/python-xyz.scm (python-android-stringslib): New variable.
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f8d107d5c1..70b51af84b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17334,3 +17334,26 @@ also be useable with other GSSAPI mechanisms.")
sending package files to the Python Package Index. This package checks that
file to ensure it completely and accurately describes your project.")
(license license:expat)))
+
+(define-public python-android-stringslib
+ (package
+ (name "python-android-stringslib")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/tyreunom/python-android-strings-lib")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0gij55qzzq1h83kfpvhai1vf78kkhyvxa6l17m2nl24454lhfin4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://framagit.org/tyreunom/python-android-strings-lib")
+ (synopsis "Android strings.xml support")
+ (description "Android Strings Lib provides support for android's strings.xml
+files. These files are used to translate strings in android apps.")
+ (license license:expat)))