summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-12 23:33:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-26 18:49:58 +0100
commit9532c0bb17f32ec2f22b7f87508a645bd2bcd935 (patch)
tree9dfc66a800276b080be394cbb853d9c81f3ba7ea
parent7261bdca4edf800a2e329369fefd3f2d43f0bf03 (diff)
downloadpatches-9532c0bb17f32ec2f22b7f87508a645bd2bcd935.tar
patches-9532c0bb17f32ec2f22b7f87508a645bd2bcd935.tar.gz
gnu: Add python-codacy-coverage.
* gnu/packages/python-check.scm (python-codacy-coverage): New variable.
-rw-r--r--gnu/packages/python-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a4d065d5e7..d322121b79 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -289,3 +290,26 @@ testing framework.")
(description "This package provides a virtualenv fixture for the py.test
framework.")
(license license:expat)))
+
+(define-public python-codacy-coverage
+ (package
+ (name "python-codacy-coverage")
+ (version "1.3.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "codacy-coverage" version))
+ (sha256
+ (base32
+ "1g0c0w56xdkmqb8slacyw5qhzrkp814ng3ddh2lkiij58y9m2imr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)); no tests
+ (propagated-inputs
+ `(("python-check-manifest" ,python-check-manifest)))
+ (home-page "https://github.com/codacy/python-codacy-coverage")
+ (synopsis "Codacy coverage reporter for Python")
+ (description "This package analyses Python test suites and reports how much
+of the code is covered by them. This tool is part of the Codacy suite for
+analysing code quality.")
+ (license license:expat)))