summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-23 02:27:10 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-27 03:54:52 +0100
commit7a4780ce9dc9fcd4c7ecca1a9458350f06c9a064 (patch)
tree5dc041e3a902e9540ddd4cb370bc27a7d68989f0
parent1ef71f522577e8b796344e072463d87e5cbae889 (diff)
downloadpatches-7a4780ce9dc9fcd4c7ecca1a9458350f06c9a064.tar
patches-7a4780ce9dc9fcd4c7ecca1a9458350f06c9a064.tar.gz
gnu: ocambuild: Update to 0.14.0.
* gnu/packages/ocaml.scm (ocamlbuild): Update to 0.14.0. [build-system]: Use ocaml-build-system.
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 10 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a278504ae0..f5becb6bf4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -233,7 +233,7 @@ functional, imperative and object-oriented styles of programming.")
(define-public ocamlbuild
(package
(name "ocamlbuild")
- (version "0.13.1")
+ (version "0.14.0")
(source
(origin
(method git-fetch)
@@ -242,31 +242,22 @@ functional, imperative and object-oriented styles of programming.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0v37vjvdqw35yvj8ipmlzmwf1jhip0hbsmcbdcn9cnj12p3mr6k7"))))
- (build-system gnu-build-system)
+ (base32 "1hb5mcdz4wv7sh1pj7dq9q4fgz5h3zg7frpiya6s8zd3ypwzq0kh"))))
+ (build-system ocaml-build-system)
(arguments
- `(#:test-target "test"
- #:tests? #f; tests require findlib
- #:make-flags
+ `(#:make-flags
(list (string-append "OCAMLBUILD_PREFIX=" (assoc-ref %outputs "out"))
(string-append "OCAMLBUILD_BINDIR=" (assoc-ref %outputs "out")
- "/bin")
+ "/bin")
(string-append "OCAMLBUILD_LIBDIR=" (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib")
+ "/lib/ocaml/site-lib")
(string-append "OCAMLBUILD_MANDIR=" (assoc-ref %outputs "out")
- "/share/man"))
+ "/share/man"))
#:phases
(modify-phases %standard-phases
- (delete 'bootstrap)
- (delete 'configure)
- (add-before 'build 'findlib-environment
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (setenv "OCAMLFIND_DESTDIR" (string-append out "/lib/ocaml/site-lib"))
- (setenv "OCAMLFIND_LDCONF" "ignore")
- #t))))))
- (native-inputs
- `(("ocaml" ,ocaml)))
+ (delete 'configure))
+ ; some failures because of changes in OCaml's error message formating
+ #:tests? #f))
(home-page "https://github.com/ocaml/ocamlbuild")
(synopsis "OCaml build tool")
(description "OCamlbuild is a generic build tool, that has built-in rules