summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-23 03:07:09 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-27 03:55:27 +0100
commit73c26d572902c2c22b2581169826505957e728e7 (patch)
treeddfaa53a1fc3b9d2c30e67e6d70ea05850b1de7e
parent7a4780ce9dc9fcd4c7ecca1a9458350f06c9a064 (diff)
downloadpatches-73c26d572902c2c22b2581169826505957e728e7.tar
patches-73c26d572902c2c22b2581169826505957e728e7.tar.gz
gnu: Add ocaml4.07-lablgtk.
* gnu/packages/ocaml.scm (ocaml4.07-lablgtk): New variable. (lablgtk)[properties]: Add variant.
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f5becb6bf4..ebe2618e6e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -811,6 +811,7 @@ Knuth’s LR(1) parser construction technique.")
(substitute* "config.make"
((ocaml) out))
#t))))))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-lablgtk))))
(home-page "http://lablgtk.forge.ocamlcore.org/")
(synopsis "GTK+ bindings for OCaml")
(description
@@ -824,6 +825,16 @@ libglade (and it an generate OCaml code from .glade files),
libpanel, librsvg and quartz.")
(license license:lgpl2.1)))
+(define-public ocaml4.07-lablgtk
+ (package
+ (inherit lablgtk)
+ (name "ocaml4.07-lablgtk")
+ (native-inputs
+ `(("ocaml" ,ocaml-4.07)
+ ("findlib" ,ocaml4.07-findlib)
+ ("pkg-config" ,pkg-config)))
+ (properties '())))
+
(define-public unison
(package
(name "unison")