summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2020-01-27 11:39:29 +0800
committer宋文武 <iyzsong@member.fsf.org>2020-01-27 11:41:45 +0800
commit47ea2ad196a41a3c3de3e5fa970b6881495c0e8f (patch)
tree181a2d578f4a7932b63e375ce8f94784bd934587
parent87858bc526a9d577760f55d05a51cb56630f845b (diff)
downloadpatches-47ea2ad196a41a3c3de3e5fa970b6881495c0e8f.tar
patches-47ea2ad196a41a3c3de3e5fa970b6881495c0e8f.tar.gz
gnu: s6: Install documentation.
* gnu/packages/skarnet.scm (s6)[arguments]: Add 'install-doc' phase.
-rw-r--r--gnu/packages/skarnet.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/skarnet.scm b/gnu/packages/skarnet.scm
index 3768695a8f..2db42240af 100644
--- a/gnu/packages/skarnet.scm
+++ b/gnu/packages/skarnet.scm
@@ -116,7 +116,7 @@ complexity.")))
(inputs `(("skalibs" ,skalibs)
("execline" ,execline)))
(arguments
- '(#:configure-flags (list
+ `(#:configure-flags (list
(string-append "--with-lib="
(assoc-ref %build-inputs "skalibs")
"/lib/skalibs")
@@ -126,7 +126,15 @@ complexity.")))
(string-append "--with-sysdeps="
(assoc-ref %build-inputs "skalibs")
"/lib/skalibs/sysdeps"))
- #:tests? #f)) ; no tests exist
+ #:tests? #f ; no tests exist
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/s6-" ,version)))
+ (copy-recursively "doc" doc)
+ #t))))))
(home-page "https://skarnet.org/software/s6")
(license isc)
(synopsis "Small suite of programs for process supervision")