summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:12:46 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit4e1254971d121806db23901a898eec2e9dcda69b (patch)
treeec33b3db03aac47daaa0136319078be80dcaa848
parent565f040df469091ffedc31f2d12ac10bf5f341b6 (diff)
downloadpatches-4e1254971d121806db23901a898eec2e9dcda69b.tar
patches-4e1254971d121806db23901a898eec2e9dcda69b.tar.gz
gnu: Add ghc-annotated-wl-pprint.
* gnu/packages/haskell.scm (ghc-annotated-wl-pprint): New variable.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dde297d6aa..59cb473601 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1375,6 +1375,31 @@ optimized for performance critical use, both in terms of large data quantities
and high speed.")
(license bsd-3)))
+(define-public ghc-annotated-wl-pprint
+ (package
+ (name "ghc-annotated-wl-pprint")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/annotated-wl-pprint"
+ "/annotated-wl-pprint-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "061xfz6qany3wf95csl8dcik2pz22cn8iv1qchhm16isw5zjs9hc"))))
+ (build-system haskell-build-system)
+ (home-page
+ "https://github.com/david-christiansen/annotated-wl-pprint")
+ (synopsis
+ "The Wadler/Leijen Pretty Printer, with annotation support")
+ (description "This is a modified version of wl-pprint, which was based on
+Wadler's paper \"A Prettier Printer\". This version allows the library user
+to annotate the text with semantic information, which can later be rendered in
+a variety of ways.")
+ (license bsd-3)))
+
(define-public ghc-split
(package
(name "ghc-split")