summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-23 16:20:00 +0100
committerChristopher Baines <mail@cbaines.net>2020-01-24 21:30:58 +0000
commit3e67182fb1b928a695718441124bec14a86ec7be (patch)
treef7e69cab3c3ae340b11674ccdb5eece3d6f262a6
parent1b0290255399cdd695a4a669d886036654bf3a57 (diff)
downloadpatches-3e67182fb1b928a695718441124bec14a86ec7be.tar
patches-3e67182fb1b928a695718441124bec14a86ec7be.tar.gz
gnu: Add megatools.
* gnu/packages/sync.scm (megatools): New variable. (megacmd)[description]: Cross-reference the two packages in the description. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/sync.scm43
1 files changed, 42 insertions, 1 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 0bde5d0a2c..d4a48c48c5 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -39,6 +39,8 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages documentation)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages golang)
#:use-module (gnu packages image)
#:use-module (gnu packages linux)
@@ -97,9 +99,48 @@
(description "MEGAcmd provides non UI access to MEGA services. It intends
to offer all the functionality of a MEGA account via commands. It features
synchronization, backup of local folders into a MEGA account and a
-webdav/streaming server.")
+webdav/streaming server.
+
+See also: megatools, a third-party alternative more commonly packaged in other
+distributions.")
(license (list license:bsd-2 license:gpl3+))))
+(define-public megatools
+ (package
+ (name "megatools")
+ (version "1.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://megatools.megous.com/builds/megatools-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12n32w5mqvpk0hvh9yg9qkj9i0g2wp7jp9rq28bnqs94iv3897hp"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ;; For documentation
+ ("asciidoc" ,asciidoc)))
+ (inputs
+ `(("curl" ,curl)
+ ("glib" ,glib)
+ ("openssl" ,openssl)))
+ (home-page "https://megatools.megous.com/")
+ (synopsis "Command line client application for mega.nz")
+ (description "Megatools is a collection of programs for accessing the mega.nz service
+from the command line.
+
+Megatools allow you to copy individual files as well as entire directory trees to and from
+the cloud. You can also perform streaming downloads for example to preview videos and
+audio files, without needing to download the entire file first.
+
+Megatools are robust and optimized for fast operation - as fast as Mega servers allow.
+Memory requirements and CPU utilization are kept at minimum.
+
+See also: megacmd, the official tool set by MEGA.")
+ (license license:gpl2)))
+
(define-public owncloud-client
(package
(name "owncloud-client")