summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-03 14:49:55 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-03 14:50:29 +0100
commit1575dcd134f4fae7255787293f4988bbd043de95 (patch)
treef28435580023f52e9cddc1067c4be6fad56de91d
parentdd1937d75dd0fb21402515ca56e06cca2ee095a7 (diff)
downloadpatches-1575dcd134f4fae7255787293f4988bbd043de95.tar
patches-1575dcd134f4fae7255787293f4988bbd043de95.tar.gz
gnu: grep: Skip timing-sensitive test.
This avoids failures on loaded machines as seen at <http://hydra.gnu.org/build/906900/log/raw>. * gnu/packages/patches/grep-timing-sensitive-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/base.scm (grep): Use it.
-rw-r--r--gnu-system.am3
-rw-r--r--gnu/packages/base.scm4
-rw-r--r--gnu/packages/patches/grep-timing-sensitive-test.patch15
3 files changed, 20 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index b8a3e2b06b..ce7b908b0a 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014, 2015 Mark H Weaver <mhw@netris.org>
#
@@ -498,6 +498,7 @@ dist_patch_DATA = \
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
gnu/packages/patches/gobject-introspection-cc.patch \
gnu/packages/patches/gobject-introspection-girepository.patch \
+ gnu/packages/patches/grep-timing-sensitive-test.patch \
gnu/packages/patches/grub-gets-undeclared.patch \
gnu/packages/patches/grub-freetype.patch \
gnu/packages/patches/guile-1.8-cpp-4.5.patch \
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a55711e9ea..a7b74cfb93 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -80,7 +80,9 @@ command-line arguments, multiple languages, and so on.")
version ".tar.xz"))
(sha256
(base32
- "1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))))
+ "1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))
+ (patches
+ (list (search-patch "grep-timing-sensitive-test.patch")))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl))) ;some of the tests require it
(synopsis "Print lines matching a pattern")
diff --git a/gnu/packages/patches/grep-timing-sensitive-test.patch b/gnu/packages/patches/grep-timing-sensitive-test.patch
new file mode 100644
index 0000000000..8cfcc848bc
--- /dev/null
+++ b/gnu/packages/patches/grep-timing-sensitive-test.patch
@@ -0,0 +1,15 @@
+Skip this performance regression test.
+
+The test measures things on the order of 20ms. On a loaded machine, we
+have seen enough variation that the test would fail.
+
+--- grep-2.22/tests/long-pattern-perf 2016-01-03 12:52:38.491575007 +0100
++++ grep-2.22/tests/long-pattern-perf 2016-01-03 12:53:39.768464687 +0100
+@@ -16,6 +16,7 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
++exit 77
+ . "${srcdir=.}/init.sh"; path_prepend_ ../src
+
+ fail=0