summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:54:56 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:46 -0400
commitede4f50c6b1d29401fe14908dfa96f6355feaf7e (patch)
tree7ad41601fe6cb0513749f34a30281dc8c2992cf9
parent3a4d3838d62239e9273506fe0577857114f11c1b (diff)
downloadpatches-ede4f50c6b1d29401fe14908dfa96f6355feaf7e.tar
patches-ede4f50c6b1d29401fe14908dfa96f6355feaf7e.tar.gz
gnu: Add go-github-com-golang-groupcache-lru.
* gnu/packages/syncthing.scm (go-github-com-golang-groupcache-lru): New variable.
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index fdf6f464ef..96bebadc6f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -256,3 +256,30 @@ generation features. This code generation is used to achieve:
@end itemize")
(home-page "https://github.com/gogo/protobuf")
(license bsd-3))))
+
+(define-public go-github-com-golang-groupcache-lru
+ (let ((commit "72d04f9fcdec7d3821820cc4a6f150eae553639a")
+ (revision "0"))
+ (package
+ (name "go-github-com-golang-groupcache-lru")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang/groupcache")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1l3ryh7bq1f2mhr3sd3x1wav99pd27r8l3ydgqh375wn4x7v5qd6"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/golang/groupcache/lru"
+ #:unpack-path "github.com/golang/groupcache"))
+ (synopsis "Groupcache is a caching and cache-filling library")
+ (description "Groupcache is a caching and cache-filling library, intended
+as a replacement for memcached in many cases. It provides a data loading
+mechanism with caching and de-duplication that works across a set of peer
+processes.")
+ (home-page "https://github.com/golang/groupcache")
+ (license asl2.0))))