summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-22 12:18:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-22 14:17:14 +0200
commitdf58cc9c568b4f18af3a4eb8e19f501e2c8ba81c (patch)
treeab0cd07dc2514f129935aa1f34d301bcf09cfb1b
parent659204ff2c15b2b8d6c0bb04c0d36bfcb5f18226 (diff)
downloadpatches-df58cc9c568b4f18af3a4eb8e19f501e2c8ba81c.tar
patches-df58cc9c568b4f18af3a4eb8e19f501e2c8ba81c.tar.gz
gnu: pass-git-helper: Don't use unstable tarball.
* gnu/packages/password-utils.scm (pass-git-helper)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/password-utils.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 98d7effd3c..3931e8a693 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -752,12 +752,14 @@ winner of the 2015 Password Hashing Competition.")
(version "0.3.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/languitar/pass-git-helper/archive/release-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/languitar/pass-git-helper")
+ (commit (string-append "release-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0lz5ncy44pz7z1j2nnyildx8sq33zi3xvg5nkwg25n11nasqh2xn"))))
+ "0vyzmfzyr6ghaglr09px2q6k38zyv1hw25j14z7if7nncj1i4i5d"))))
(build-system python-build-system)
(arguments
`(#:phases