summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:26:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:26:53 +0200
commitcc17b07a02b021cb1f6f1b0914f7aed4c3a7304c (patch)
tree902c13d2e66a41168258509b75c98784eef7d406
parentfe1506a0ca5c48ef927bc207a6d08c7573c1ae25 (diff)
downloadpatches-cc17b07a02b021cb1f6f1b0914f7aed4c3a7304c.tar
patches-cc17b07a02b021cb1f6f1b0914f7aed4c3a7304c.tar.gz
gnu: jimtcl: Don't use unstable tarball.
* gnu/packages/embedded.scm (jimtcl)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/embedded.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index d5ea86225e..b655a88129 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -461,14 +461,14 @@ SEGGER J-Link and compatible devices.")
(name "jimtcl")
(version "0.77")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/msteveb/jimtcl"
- "/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/msteveb/jimtcl")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1cmk3qscqckg70chjyimzxa2qcka4qac0j4wq908kiijp45cax08"))))
+ "06d9gdgvi6cwd6pjg3xig0kkjqm6kgq3am8yq1xnksyz2n09f0kp"))))
(build-system gnu-build-system)
(arguments
`(#:phases