summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-23 11:18:14 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-23 11:26:55 +0100
commitb93cde3d8cf52af02083cdc23e5819699f5aea67 (patch)
treed5223bf6cfa4ce3193cf810a3a8ee4a950f892f7
parent46378df05010f3f9f54fe7d0f3a17c1abc238166 (diff)
downloadpatches-b93cde3d8cf52af02083cdc23e5819699f5aea67.tar
patches-b93cde3d8cf52af02083cdc23e5819699f5aea67.tar.gz
gnu: guile-present: Install .go files in /site-ccache.
* gnu/packages/gtk.scm (guile-present)[source]: Add 'modules' and 'snippet'.
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 93e90fa450..6b61e9c7a9 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -946,7 +946,14 @@ images onto Cairo surfaces.")
(sha256
(base32
"1qam447m05sxxv6x8dlzg7qnyfc4dh8apjw1idpfhpns671gfr6m"))
- (patches (search-patches "guile-present-coding.patch"))))
+ (patches (search-patches "guile-present-coding.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Install .go files in the right place.
+ (substitute* "Makefile.in"
+ (("/ccache") "/site-ccache"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases