summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-22 12:28:48 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-22 14:17:31 +0200
commitb70f9ad1654bb2e363257ff2365d56cce9f6f2e0 (patch)
tree1a6d50deb881df4e303737d2ea56c87de7e9e180
parentdf58cc9c568b4f18af3a4eb8e19f501e2c8ba81c (diff)
downloadpatches-b70f9ad1654bb2e363257ff2365d56cce9f6f2e0.tar
patches-b70f9ad1654bb2e363257ff2365d56cce9f6f2e0.tar.gz
gnu: pass-git-helper: Update to 1.1.0.
* gnu/packages/password-utils.scm (pass-git-helper): Update to 1.1.0. [arguments]: Update 'patch-pass-path phase. Add 'pre-check phase. [native-inputs]: Add python-pytest, python-pytest-mock.
-rw-r--r--gnu/packages/password-utils.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 3931e8a693..989d27a2e0 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -749,17 +749,17 @@ winner of the 2015 Password Hashing Competition.")
(define-public pass-git-helper
(package
(name "pass-git-helper")
- (version "0.3.1")
+ (version "1.1.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/languitar/pass-git-helper")
- (commit (string-append "release-" version))))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0vyzmfzyr6ghaglr09px2q6k38zyv1hw25j14z7if7nncj1i4i5d"))))
+ "18nvwlp0w4aqj268wly60rnjzqw2d8jl0hbs6bkwp3hpzzz5g6yd"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -768,12 +768,19 @@ winner of the 2015 Password Hashing Competition.")
(lambda* (#:key inputs #:allow-other-keys)
(let* ((password-store (assoc-ref inputs "password-store"))
(pass (string-append password-store "/bin/pass")))
- (substitute* "pass-git-helper"
+ (substitute* "passgithelper.py"
(("'pass'") (string-append "'" pass "'")))
- #t))))))
+ #t)))
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "HOME" (getcwd))
+ #t)))))
(inputs
`(("python-pyxdg" ,python-pyxdg)
("password-store" ,password-store)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-mock" ,python-pytest-mock)))
(home-page "https://github.com/languitar/pass-git-helper")
(synopsis "Git credential helper interfacing with pass")
(description "pass-git-helper is a git credential helper which allows to