summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:07:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-24 10:07:58 +0200
commit9be1f2b77c93034378938a08f4b02a693a305913 (patch)
tree95c3992552030d01eb8f73eebb3430b00c82a081
parentc4bdd78a6ac9b3442817084c7e9298b09234db01 (diff)
downloadpatches-9be1f2b77c93034378938a08f4b02a693a305913.tar
patches-9be1f2b77c93034378938a08f4b02a693a305913.tar.gz
gnu: openspin: Don't use unstable tarball.
* gnu/packages/embedded.scm (openspin)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/embedded.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 1f73e78fe0..b35c0a663c 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Clément Lassieur <clement@lassieur.org>
;;;
@@ -753,13 +753,14 @@ Propeller micro-controller development.")
(name "openspin")
(version "1.00.78")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/parallaxinc/"
- "OpenSpin/archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/parallaxinc/OpenSpin")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1k2dbz1v604g4r2d9qhckg2m8dnhiya760mbsqfsg4waxal87yb7"))))
+ "0ghk8hj4717ydhqzx2pfs6737s1cxng6sgg2xgbkwvcfclxdbrd0"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests