summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-23 09:33:57 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-23 11:26:55 +0100
commit93d94134cc7268c6ad87581b8c3e2737e50d9a7d (patch)
tree90d8e38b185ddcf98742a64a3ee4410df5497c12
parent6e6aab0b6af0bf60b2c7276fa9ee6ca6da9aef88 (diff)
downloadpatches-93d94134cc7268c6ad87581b8c3e2737e50d9a7d.tar
patches-93d94134cc7268c6ad87581b8c3e2737e50d9a7d.tar.gz
gnu: haunt: Add "guile3.0-haunt" variant.
* gnu/packages/guile-xyz.scm (haunt)[source]: Add 'modules' and 'snippet'. [arguments]: In 'wrap-haunt' phase, assume that INPUTS might lack "guile-reader". (guile3.0-haunt): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b07599c068..09c12b97fd 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1955,7 +1955,15 @@ inspired by the SCSH regular expression system.")
version ".tar.gz"))
(sha256
(base32
- "056z4znikk83nr5mr0x2ac3iinqbywa2bvb37mhr566a1q50isfc"))))
+ "056z4znikk83nr5mr0x2ac3iinqbywa2bvb37mhr566a1q50isfc"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Allow builds with Guile 3.0.
+ (substitute* "configure"
+ (("2\\.2 2\\.0")
+ "3.0 2.2 2.0"))
+ #t))))
(build-system gnu-build-system)
(arguments
`(#:modules ((ice-9 match) (ice-9 ftw)
@@ -1970,8 +1978,11 @@ inspired by the SCSH regular expression system.")
(bin (string-append out "/bin"))
(site (string-append
out "/share/guile/site"))
- (deps (list (assoc-ref inputs "guile-reader")
- (assoc-ref inputs "guile-commonmark"))))
+ (guile-reader (assoc-ref inputs "guile-reader"))
+ (deps `(,@(if guile-reader
+ (list guile-reader)
+ '())
+ ,(assoc-ref inputs "guile-commonmark"))))
(match (scandir site)
(("." ".." version)
(let ((modules (string-append site "/" version))
@@ -2009,6 +2020,15 @@ interface for reading articles in any format.")
(home-page "http://haunt.dthompson.us")
(license license:gpl3+)))
+(define-public guile3.0-haunt
+ (package
+ (inherit haunt)
+ (name "guile3.0-haunt")
+ (inputs `(("guile" ,guile-3.0)))
+ (propagated-inputs
+ ;; XXX: Guile-Reader is currently unavailable for Guile 3.0 so strip it.
+ `(("guile-commonmark" ,guile3.0-commonmark)))))
+
(define-public guile2.0-haunt
(package
(inherit haunt)