summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoJo <jo@jo.zone>2020-01-15 15:43:03 +0100
committerLeo Famulari <leo@famulari.name>2020-01-23 16:42:13 -0500
commit84436be094776b8b9a5893eb7fb4888bd7ca8b79 (patch)
treebd6a756168e62b8f157d11a6e18fb16cf02468dc
parenta78364e91cca5faefc3d24619813487053bd6542 (diff)
downloadpatches-84436be094776b8b9a5893eb7fb4888bd7ca8b79.tar
patches-84436be094776b8b9a5893eb7fb4888bd7ca8b79.tar.gz
gnu: Add ghc-llvm-hs-pure.
* gnu/packages/haskell-xyz.scm (ghc-llvm-hs-pure): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fd2f11ce72..aaabc02c13 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 JoJo <jo@jo.zone>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6704,6 +6705,35 @@ ByteString, for types that support input and output, and for types that
can handle infinite lists.")
(license license:bsd-3)))
+(define-public ghc-llvm-hs-pure
+ (package
+ (name "ghc-llvm-hs-pure")
+ (version "9.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/llvm-hs-pure/"
+ "llvm-hs-pure-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pxb5ah8r5pzpz2ibqw3g9g1isigb4z7pbzfrwr8kmcjn74ab3kf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-fail" ,ghc-fail)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
+ (home-page "https://github.com/llvm-hs/llvm-hs/")
+ (synopsis "Pure Haskell LLVM functionality (no FFI)")
+ (description "llvm-hs-pure is a set of pure Haskell types and functions
+for interacting with LLVM. It includes an algebraic datatype (ADT) to represent
+LLVM IR. The llvm-hs package builds on this one with FFI bindings to LLVM, but
+llvm-hs-pure does not require LLVM to be available.")
+ (license license:bsd-3)))
+
(define-public ghc-logging-facade
(package
(name "ghc-logging-facade")