summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-22 05:27:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-22 06:20:00 +0100
commit82f81ffac6d3cacfab33fa6bed3758eb974cb29f (patch)
treefe16f8ee8b6bf49330b281e01b27e69a7d45883c
parent542d64fd8439eed5c1d6acead86c2244a703e468 (diff)
downloadpatches-82f81ffac6d3cacfab33fa6bed3758eb974cb29f.tar
patches-82f81ffac6d3cacfab33fa6bed3758eb974cb29f.tar.gz
gnu: gtkwave: Prefer mirror://sourceforge source URI.
* gnu/packages/fpga.scm (gtkwave)[source]: Add URI.
-rw-r--r--gnu/packages/fpga.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 988129f373..4411dfe895 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Theodoros Foradis <theodoros@foradis.org>
-;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Amin Bandali <mab@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -302,13 +302,16 @@ Includes the actual FTDI connector.")
(package
(name "gtkwave")
(version "3.3.101")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://gtkwave.sourceforge.net/"
- "gtkwave-" version ".tar.gz"))
- (sha256
- (base32
- "1j6capxwgi8aj3sgqg1r7161icni9y8y93g1rl3bzd3s40jcyhsz"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "mirror://sourceforge/gtkwave/"
+ "gtkwave-" version "/"
+ "gtkwave-" version ".tar.gz")
+ (string-append "http://gtkwave.sourceforge.net/"
+ "gtkwave-" version ".tar.gz")))
+ (sha256
+ (base32 "1j6capxwgi8aj3sgqg1r7161icni9y8y93g1rl3bzd3s40jcyhsz"))))
(build-system gnu-build-system)
(native-inputs
`(("gperf" ,gperf)