summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-23 09:34:56 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-23 11:26:55 +0100
commit3de0d20b80248179f03ee54091c05c8896df1763 (patch)
tree736bae22a17d7c3e3f3f140307c8dca3064f45da
parent93d94134cc7268c6ad87581b8c3e2737e50d9a7d (diff)
downloadpatches-3de0d20b80248179f03ee54091c05c8896df1763.tar
patches-3de0d20b80248179f03ee54091c05c8896df1763.tar.gz
gnu: mcron: Add "guile3.0-mcron" variant.
* gnu/packages/guile-xyz.scm (mcron)[arguments]: In 'fix-finding-guile' phase, add "3.0". (guile3.0-mcron): New variable.
-rw-r--r--gnu/packages/guile-xyz.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 09c12b97fd..c3c48456fb 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2132,7 +2132,7 @@ is no support for parsing block and inline level HTML.")
(add-after 'unpack 'fix-finding-guile
(lambda _
(substitute* "configure"
- (("2\\.0") "2.2 2.0"))
+ (("2\\.0") "3.0 2.2 2.0"))
#t))
(add-before 'check 'adjust-tests
(lambda _
@@ -2162,6 +2162,12 @@ Guile, so its configuration can be written in Scheme; the original cron
format is also supported.")
(license license:gpl3+)))
+(define-public guile3.0-mcron
+ (package
+ (inherit mcron)
+ (name "guile3.0-mcron")
+ (inputs `(("guile" ,guile-3.0)))))
+
(define-public mcron2
;; This was mthl's mcron development branch, and it became mcron 1.1.
(deprecated-package "mcron2" mcron))