summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-23 16:00:29 +0000
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-23 16:50:00 +0000
commit37bb0d1eafb3f08a204aed8c928cbf7cbc69cd19 (patch)
tree5f8300595d8867d3bbd79a7b76224b94b4c28b75
parent09ecd9a7944ca8af017a92228442d8ec84c15f58 (diff)
downloadpatches-37bb0d1eafb3f08a204aed8c928cbf7cbc69cd19.tar
patches-37bb0d1eafb3f08a204aed8c928cbf7cbc69cd19.tar.gz
gnu: fenics: Update to 2019.1.0.post0.
* gnu/packages/simulation.scm (fenics): Update to 2019.1.0.post0. [arguments]: In the 'pre-check' phase, add three more demos to the list of demos that are skipped.
-rw-r--r--gnu/packages/simulation.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 5c1931631f..2f07e996a2 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -633,12 +633,20 @@ user interface to the FEniCS core components and external libraries.")
,%openmpi-setup)
(add-before 'check 'pre-check
(lambda _
- ;; Exclude tests that require meshes supplied by git-lfs.
+ ;; Exclude three tests that generate
+ ;; 'NotImplementedError' in matplotlib version 3.1.2.
+ ;; See
+ ;; <https://github.com/matplotlib/matplotlib/issues/15382>.
+ ;; Also exclude tests that require meshes supplied by
+ ;; git-lfs.
(substitute* "demo/test.py"
(("(.*stem !.*)" line)
(string-append
line "\n"
"excludeList = [\n"
+ "'built-in-meshes', \n"
+ "'hyperelasticity', \n"
+ "'elasticity', \n"
"'multimesh-quadrature', \n"
"'multimesh-marking', \n"
"'mixed-poisson-sphere', \n"