summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-22 15:14:05 +0000
committerPaul Garlick <pgarlick@tourbillion-technology.com>2020-01-23 16:49:59 +0000
commit09ecd9a7944ca8af017a92228442d8ec84c15f58 (patch)
treebc6b01477e2752f46cdcca9be17c3b47be0accb7
parentec8dff89804320ba9ac237b9e479dac8c217552e (diff)
downloadpatches-09ecd9a7944ca8af017a92228442d8ec84c15f58.tar
patches-09ecd9a7944ca8af017a92228442d8ec84c15f58.tar.gz
gnu: fenics-dolfin: Update to 2019.1.0.post0.
* gnu/packages/simulation.scm (fenics-dolfin): Update to 2019.1.0.post0. [source](snippet): Remove three substitutions that are no longer needed. [native-inputs]: Use compatible version of CATCH. [arguments]: Use CMAKE version 3.15.5 to avoid EXCLUDE_FROM_ALL regression. See <https://issues.guix.gnu.org/issue/38060>.
-rw-r--r--gnu/packages/simulation.scm33
1 files changed, 7 insertions, 26 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 8ab58c29b4..5c1931631f 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -431,7 +431,7 @@ FFC is part of the FEniCS Project.")
(define-public fenics-dolfin
(package
(name "fenics-dolfin")
- (version "2018.1.0.post1")
+ (version "2019.1.0.post0")
(source
(origin
(method url-fetch)
@@ -441,7 +441,7 @@ FFC is part of the FEniCS Project.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12zkk8j3xsg6l8p0ggwsl03084vlcivw4h99b7z9kndg7k89b3ya"))
+ "1m91hwcq5gfj4qqswp8l8kj58nia48f0n4kq13w0xqj4biq7rla0"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -452,30 +452,10 @@ FFC is part of the FEniCS Project.")
(("#include.*")
"#include <catch.hpp>\n"))
(substitute* "test/unit/cpp/CMakeLists.txt"
- ;; Add extra include directories required by the unit tests.
- (("(^target_link_libraries.*)" line)
- (string-append line "\n"
- "target_include_directories("
- "unittests PRIVATE "
- "${DOLFIN_SOURCE_DIR} "
- "${DOLFIN_SOURCE_DIR}/dolfin "
- "${DOLFIN_BINARY_DIR})\n"))
+ ;; Specify directory to find the header file.
(("(^set\\(CATCH_INCLUDE_DIR ).*(/catch\\))" _ front back)
(string-append front
- "$ENV{CATCH_DIR}"
- "/include" back "\n")))
- (substitute* "demo/CMakeLists.txt"
- ;; Add extra include directories required by the demo tests.
- (("(^#find_package.*)" line)
- (string-append line "\n"
- "include_directories("
- "${DOLFIN_SOURCE_DIR} "
- "${DOLFIN_SOURCE_DIR}/dolfin "
- "${DOLFIN_BINARY_DIR})\n")))
- (substitute* "dolfin/nls/PETScSNESSolver.cpp"
- ;; Remove SNESTEST mapping. The SNESTEST symbol was removed
- ;; from PETSc at version 3.10.3.
- ((".*SNESTEST.*") "" ))
+ "$ENV{CATCH_DIR}/include" back "\n")))
#t))))
(build-system cmake-build-system)
(inputs
@@ -492,14 +472,15 @@ FFC is part of the FEniCS Project.")
("sundials" ,sundials-openmpi)
("zlib" ,zlib)))
(native-inputs
- `(("catch" ,catch-framework2)
+ `(("catch" ,catch-framework2-1)
("pkg-config" ,pkg-config)))
(propagated-inputs
`(("ffc" ,python-fenics-ffc)
("petsc" ,petsc-openmpi)
("slepc" ,slepc-openmpi)))
(arguments
- `(#:configure-flags
+ `(#:cmake ,cmake-3.15.5
+ #:configure-flags
`("-DDOLFIN_ENABLE_DOCS:BOOL=OFF"
"-DDOLFIN_ENABLE_HDF5:BOOL=ON"
"-DDOLFIN_ENABLE_MPI:BOOL=ON"