summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 04:23:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-23 00:06:51 +0100
commit9aee5c45c1c85425559f5a33955cd3ec6ad97aee (patch)
tree867a0ec8f2d920e87f94ba3c4084f1bb7b410472
parentc7dd15596ffd09ab40629c89e7014e51a4d7e95e (diff)
downloadpatches-9aee5c45c1c85425559f5a33955cd3ec6ad97aee.tar
patches-9aee5c45c1c85425559f5a33955cd3ec6ad97aee.tar.gz
gnu: font-adobe-source-code-pro: Don't use unstable tarball.
* gnu/packages/fonts.scm (font-adobe-source-code-pro)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/fonts.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 7d3330e17a..d16b9a16f7 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -862,18 +862,18 @@ Powerline support.")
(package
(name "font-adobe-source-code-pro")
(version "2.030R-ro-1.050R-it")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/adobe-fonts/source-code-pro/archive/"
- (regexp-substitute/global
- ;; The upstream tag uses "/" between the roman and italic
- ;; versions, so substitute our "-" separator here.
- #f "R-ro-" version 'pre "R-ro/" 'post) ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0arhhsf3i7ss39ykn73d1j8k4n8vx7115xph6jwkd970p1cxvr54"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adobe-fonts/source-code-pro.git")
+ (commit (regexp-substitute/global
+ ;; The upstream tag uses "/" between the roman and italic
+ ;; versions, so substitute our "-" separator here.
+ #f "R-ro-" version 'pre "R-ro/" 'post))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hc5kflr8xzqgdm0c3gbgb1paygznxmnivkylid69ipc7wnicx1n"))))
(build-system font-build-system)
(home-page "https://github.com/adobe-fonts/source-code-pro")
(synopsis