summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-01-23 11:22:20 +0100
committerLudovic Courtès <ludo@gnu.org>2020-01-23 11:26:56 +0100
commit897186c1554e18a187429683d2eafdbfc0caac96 (patch)
treeb9eaaa03dc31a6b11dbd013fc8768546b92e1561
parentb93cde3d8cf52af02083cdc23e5819699f5aea67 (diff)
downloadpatches-897186c1554e18a187429683d2eafdbfc0caac96.tar
patches-897186c1554e18a187429683d2eafdbfc0caac96.tar.gz
gnu: guile-present: Pass the right module directories in scripts.
* gnu/packages/gtk.scm (guile-present)[arguments]: In 'post-install' phase, remove hard-coded "2.0" and replace it by a computed effective version. Also, pass "/site-ccache" to -C.
-rw-r--r--gnu/packages/gtk.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 6b61e9c7a9..88c4b56e9d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -84,7 +84,8 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26))
+ #:use-module (srfi srfi-26)
+ #:use-module (ice-9 match))
(define-public atk
(package
@@ -956,18 +957,22 @@ images onto Cairo surfaces.")
#t))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (guile (assoc-ref inputs "guile")))
+ (guile (assoc-ref inputs "guile"))
+ (version
+ ,(match (assoc "guile" (package-inputs this-package))
+ (("guile" guile)
+ (version-major+minor (package-version guile))))))
(substitute* (find-files bin ".*")
(("guile")
(string-append guile "/bin/guile -L "
- out "/share/guile/site/2.0 -C "
- out "/share/guile/site/2.0 "))))
+ out "/share/guile/site/" version " -C "
+ out "/lib/guile/" version "/site-ccache "))))
#t)))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("guile" ,guile-2.2)))