summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-22 23:17:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-23 00:06:52 +0100
commit737a3c12cd25f76e9fb4872e0a7a1ecb61aff131 (patch)
tree66ab1e00ca3fa95932fd4a843eec11529f2d2719
parent973218a3747ad564493a976da588d286fe7d4301 (diff)
downloadpatches-737a3c12cd25f76e9fb4872e0a7a1ecb61aff131.tar
patches-737a3c12cd25f76e9fb4872e0a7a1ecb61aff131.tar.gz
gnu: libmemcached: Fix build.
* gnu/packages/databases.scm (libmemcached)[source]: Add patch. * gnu/packages/patches/libmemcached-build-with-gcc7.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/databases.scm4
-rw-r--r--gnu/packages/patches/libmemcached-build-with-gcc7.patch28
3 files changed, 32 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 51272b2dc8..46d040c507 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1165,6 +1165,7 @@ dist_patch_DATA = \
%D%/packages/patches/mcrypt-CVE-2012-4409.patch \
%D%/packages/patches/mcrypt-CVE-2012-4426.patch \
%D%/packages/patches/mcrypt-CVE-2012-4527.patch \
+ %D%/packages/patches/libmemcached-build-with-gcc7.patch \
%D%/packages/patches/mes-remove-store-name.patch \
%D%/packages/patches/mesa-skip-disk-cache-test.patch \
%D%/packages/patches/mescc-tools-boot.patch \
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ea74852ffe..ed1d1fe95b 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -370,7 +370,9 @@ applications.")
(file-name (string-append name "-" version "-checkout"))
(sha256
(base32
- "1842s4dxdh21gdr46q4dgxigidcs6dkqnbnqjwb9l8r0bqx5nb10"))))
+ "1842s4dxdh21gdr46q4dgxigidcs6dkqnbnqjwb9l8r0bqx5nb10"))
+ (patches
+ (search-patches "libmemcached-build-with-gcc7.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("memcached" ,memcached)
diff --git a/gnu/packages/patches/libmemcached-build-with-gcc7.patch b/gnu/packages/patches/libmemcached-build-with-gcc7.patch
new file mode 100644
index 0000000000..51e319d2c0
--- /dev/null
+++ b/gnu/packages/patches/libmemcached-build-with-gcc7.patch
@@ -0,0 +1,28 @@
+Author: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Wed 22 Jan 22:58:13 CET 2020
+Subject: gnu: memcached: Fix build with GCC 7.
+
+Taken verbating from this bug report:
+<https://bugs.launchpad.net/libmemcached/+bug/1663985>.
+
+diff -up ./clients/memflush.cc.old ./clients/memflush.cc
+--- ./clients/memflush.cc.old 2017-02-12 10:12:59.615209225 +0100
++++ ./clients/memflush.cc 2017-02-12 10:13:39.998382783 +0100
+@@ -39,7 +39,7 @@ int main(int argc, char *argv[])
+ {
+ options_parse(argc, argv);
+
+- if (opt_servers == false)
++ if (!opt_servers)
+ {
+ char *temp;
+
+@@ -48,7 +48,7 @@ int main(int argc, char *argv[])
+ opt_servers= strdup(temp);
+ }
+
+- if (opt_servers == false)
++ if (!opt_servers)
+ {
+ std::cerr << "No Servers provided" << std::endl;
+ exit(EXIT_FAILURE);