summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-01-21 04:29:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-01-23 00:06:51 +0100
commit31f41dbc1c162728901b9e940e42c0fd7b421d48 (patch)
treee945d53e0fd5b7b50ab10394af802bc421214d4b
parented08e4ecaee2d14e1883ce8675d69aad53da51bc (diff)
downloadpatches-31f41dbc1c162728901b9e940e42c0fd7b421d48.tar
patches-31f41dbc1c162728901b9e940e42c0fd7b421d48.tar.gz
gnu: font-adobe-source-serif-pro: Don't use unstable tarball.
* gnu/packages/fonts.scm (font-adobe-source-serif-pro)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/fonts.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index dd635bab82..358c72f07a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -912,18 +912,18 @@ work well in user interface (UI) environments.")
(package
(name "font-adobe-source-serif-pro")
(version "2.007R-ro-1.007R-it")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/adobe-fonts/source-serif-pro/archive/"
- (regexp-substitute/global
- ;; The upstream tag uses "/" between the roman and italic
- ;; versions, so substitute our "-" separator here.
- #f "R-ro-" version 'pre "R-ro/" 'post) ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1sws9k26ldqk375qsigk1zv8cq1xlvadjwvv3dqrcc3qzm1c7hwc"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/adobe-fonts/source-serif-pro.git")
+ (commit (regexp-substitute/global
+ ;; The upstream tag uses "/" between the roman and italic
+ ;; versions, so substitute our "-" separator here.
+ #f "R-ro-" version 'pre "R-ro/" 'post))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vvzfhjpi47m84bzkapylkd5fri8bdm8qng2hiylmmlw0wk4gpas"))))
(build-system font-build-system)
(home-page "https://github.com/adobe-fonts/source-serif-pro")
(synopsis