summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2017-04-30 14:55:47 +0900
committerLudovic Courtès <ludo@gnu.org>2017-05-01 17:28:20 +0200
commite93793059d4a15894e407525bdc33fd06e2b104a (patch)
tree08c73c5876893cebbe885e09a7285608c7f0a4e1
parente30c2be10da8929e42aafc7770257e84de49ffbb (diff)
downloadpatches-e93793059d4a15894e407525bdc33fd06e2b104a.tar
patches-e93793059d4a15894e407525bdc33fd06e2b104a.tar.gz
gnu: python2-urwid: Disable vterm tests.
* gnu/packages/python.scm (python2-urwid)['delete-test_vterm]: Add phase to delete problematic test modules. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 164c1f49bc..b715289773 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5509,7 +5509,18 @@ features useful for text console applications.")
(license license:lgpl2.1+)))
(define-public python2-urwid
- (package-with-python2 python-urwid))
+ (let ((python2-urwid (package-with-python2 python-urwid)))
+ (package
+ (inherit python2-urwid)
+ (arguments
+ (append
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; Disable the vterm tests because of non-deterministic failures
+ ;; with Python 2. See https://github.com/urwid/urwid/issues/230.
+ (add-after 'unpack 'delete-test_vterm.py
+ (delete-file "urwid/tests/test_vterm.py"))))
+ (package-arguments python-urwid))))))
(define-public python-openid
(package