summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-19 23:44:36 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 21:53:52 +0100
commitd18116d9b5b0cafd4390326b57c487d51804a9e8 (patch)
tree5a606ecbccbeb7a90d410116a24bca3e3ed724a1
parent80af75abcf81406fa53c3cae1a31cd42124bfa9f (diff)
downloadpatches-d18116d9b5b0cafd4390326b57c487d51804a9e8.tar
patches-d18116d9b5b0cafd4390326b57c487d51804a9e8.tar.gz
gnu: libsrtp: Build shared library.
* gnu/packages/telephony.scm (libsrtp)[arguments]: Add #:phases.
-rw-r--r--gnu/packages/telephony.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index b9e3d6258a..a645c58562 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -261,7 +261,19 @@ internet.")
("procps" ,procps)))
(build-system gnu-build-system)
(arguments
- '(#:test-target "runtest"))
+ '(#:test-target "runtest"
+ #:phases (modify-phases %standard-phases
+ (add-after 'build 'build-shared
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ ;; Build the shared library separately because
+ ;; the test runner requires a static build.
+ (apply invoke "make" "shared_library" make-flags)
+ #t))
+ (add-after 'install 'remove-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libsrtp2.a"))
+ #t)))))
(synopsis "Secure RTP (SRTP) Reference Implementation")
(description
"This package provides an implementation of the Secure Real-time Transport