summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-21 17:24:31 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-21 17:24:31 +0200
commita8a5cc6841c1b45f58303eb0f7d97e4b7e1d49c8 (patch)
tree529e8e997203dadc14d97760478d3f8299e429c2
parentb86409a76fcdf8e1637505e55e7dc8c1baaf133d (diff)
downloadpatches-a8a5cc6841c1b45f58303eb0f7d97e4b7e1d49c8.tar
patches-a8a5cc6841c1b45f58303eb0f7d97e4b7e1d49c8.tar.gz
gnu: Add rust-heck-0.3.
* gnu/packages/crates-io.scm (rust-heck-0.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d40b50c8c4..831c4959c1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4674,6 +4674,32 @@ heap.")
total runtime size of an object on the heap")
(license license:mpl2.0)))
+(define-public rust-heck-0.3
+ (package
+ (name "rust-heck")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "heck" version))
+ (file-name (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "01a2v7yvkiqxakdqz4hw3w3g4sm52ivz9cs3qcsv2arxsmw4wmi0"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-unicode-segmentation" ,rust-unicode-segmentation-1.3))))
+ (home-page "https://github.com/withoutboats/heck")
+ (synopsis "Case conversion library")
+ (description
+ "This library exists to provide case conversion between common cases like
+CamelCase and snake_case. It is intended to be unicode aware, internally
+consistent, and reasonably well performing.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-hex-0.4
(package
(name "rust-hex")