summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2017-06-26 15:28:12 +0100
committerLudovic Courtès <ludo@gnu.org>2017-06-29 15:21:18 +0200
commita73e7dd3b029fccec55afbbecf762cc8231dee5d (patch)
treed4bb2fe40a6ed5ee70049d1817c26ef15f6a8566
parentb786661309ab8194eb5e5a3ebf55d35be2e0bb01 (diff)
downloadpatches-a73e7dd3b029fccec55afbbecf762cc8231dee5d.tar
patches-a73e7dd3b029fccec55afbbecf762cc8231dee5d.tar.gz
gnu: Add procenv.
* gnu/packages/linux.scm (procenv): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 413f935901..641c307a0b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 nee <nee-git@hidamari.blue>
+;;; Copyright © 2017 Dave Love <fx@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -98,6 +99,8 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages groff)
+ #:use-module (gnu packages selinux)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
@@ -4140,3 +4143,28 @@ NexGen, Rise, and SiS CPUs.")
to data over the Media Transfer Protocol (MTP). Unprivileged users can mount
the MTP device as a filesystem.")
(license license:gpl3)))
+
+(define-public procenv
+ (package
+ (name "procenv")
+ (version "0.49")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/jamesodhunt/procenv/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0brzf6185hb76imw107cl21c8lzwiywkxi3jknihrk86bvvicd0d"))))
+ (build-system gnu-build-system)
+ (arguments `(#:configure-flags '("--disable-silent-rules")))
+ (inputs `(("expat" ,expat) ("libcap" ,libcap) ("check" ,check)
+ ("groff" ,groff) ; for tests
+ ("libselinux" ,libselinux)))
+ (synopsis "Utility to show process environment")
+ (description "Procenv is a command-line tool that displays as much detail about
+itself and its environment as possible. It can be used as a test
+tool, to understand the type of environment a process runs in, and for
+comparing system environments.")
+ (home-page "http://github.com/jamesodhunt/procenv/")
+ (license license:gpl3+)))