summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-20 23:26:18 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-21 01:11:20 +0100
commit795cf2a3b57c73eeec0fe853dbf47e140e44ff56 (patch)
treebd7774a0878d8b70b04b20d8e1877b603c6e9e7e
parentc2eb8c7ef7941e9c5791de2b2447a8d48adabbb4 (diff)
downloadpatches-795cf2a3b57c73eeec0fe853dbf47e140e44ff56.tar
patches-795cf2a3b57c73eeec0fe853dbf47e140e44ff56.tar.gz
gnu: ocaml-qcheck: Update to 0.12.
* gnu/packages/ocaml.scm (ocaml-qcheck): Update to 0.12.
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 34018ea5f6..3beead8fd0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1140,7 +1140,7 @@ GNU CC attributes. It provides also a C pretty printer as an example of use.")
(define-public ocaml-qcheck
(package
(name "ocaml-qcheck")
- (version "0.11")
+ (version "0.12")
(source
(origin
(method git-fetch)
@@ -1149,14 +1149,22 @@ GNU CC attributes. It provides also a C pretty printer as an example of use.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0d2wih4zxn2zm7kxd9dnf5nlp838km3vz6wv80fa3m51609fb24i"))))
+ (base32 "1llnfynhlndwyjig7wrayjnds2b3mggp5lw20dwxhn2i2lkkb22m"))))
(build-system dune-build-system)
(arguments
- `(#:test-target "."))
- (native-inputs
+ `(#:test-target "."
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-deprecated
+ (lambda _
+ (substitute* "src/core/QCheck.ml"
+ (("Pervasives.compare") "compare"))
+ #t)))))
+ (propagated-inputs
`(("ocaml-alcotest" ,ocaml-alcotest)
- ("ocaml-ounit" ,ocaml-ounit)
- ("ocamlbuild" ,ocamlbuild)))
+ ("ocaml-ounit" ,ocaml-ounit)))
+ (native-inputs
+ `(("ocamlbuild" ,ocamlbuild)))
(home-page "https://github.com/c-cube/qcheck")
(synopsis "QuickCheck inspired property-based testing for OCaml")
(description "QuickCheck inspired property-based testing for OCaml. This